diff rogue5/configure.ac @ 312:029c1f5c5588

Update the Autoconf files. These are mostly automatic updates for obsolete macros.
author John "Elwin" Edwards
date Tue, 11 May 2021 22:30:03 -0400
parents fe6b7a1a6dfc
children aab761616489
line wrap: on
line diff
--- a/rogue5/configure.ac	Tue May 04 21:03:47 2021 -0400
+++ b/rogue5/configure.ac	Tue May 11 22:30:03 2021 -0400
@@ -1,8 +1,8 @@
 #                                               -*- Autoconf -*-
 # Process this file with autoconf to produce a configure script.
 
-AC_PREREQ(2.56)
-AC_INIT([Rogue],[5.4.5], [yendor@rogueforge.net], [rogue5])
+AC_PREREQ([2.69])
+AC_INIT([Rogue],[5.4.5],[elwin@sdf.org],[rogue5])
 AC_CONFIG_SRCDIR([armor.c])
 AC_CONFIG_HEADER([config.h])
 AC_CONFIG_FILES([Makefile rogue.6 rogue.me rogue.html])
@@ -29,7 +29,6 @@
 AC_PROG_GCC_TRADITIONAL
 AC_FUNC_LSTAT
 AC_FUNC_LSTAT_FOLLOWS_SLASHED_SYMLINK
-AC_TYPE_SIGNAL
 AC_FUNC_STAT
 AC_FUNC_VPRINTF
 AC_CHECK_FUNCS([erasechar killchar alarm getpass memset setenv strchr nlist _spawnl spawnl getpwuid loadav getloadavg strerror setresgid setregid setgid setresuid setreuid setuid getuid getgid])
@@ -57,11 +56,11 @@
 AC_SUBST(DOCS_NROFF)
 AC_SUBST(DOCS_NONE)
 
-AC_ARG_WITH(program-name, AC_HELP_STRING([--with-program-name=NAME],[alternate executable name]),[progname="$withval" ], [progname="rogue5"] )
+AC_ARG_WITH(program-name, AS_HELP_STRING([--with-program-name=NAME],[alternate executable name]),[progname="$withval" ], [progname="rogue5"] )
 PROGRAM=$progname
 AC_SUBST(PROGRAM)
 
-AC_ARG_ENABLE(setgid, AC_HELP_STRING([--enable-setgid=NAME],[install executable as setgid with group ownership of NAME @<:@default=no@:>@]),[],[])
+AC_ARG_ENABLE(setgid, AS_HELP_STRING([--enable-setgid=NAME],[install executable as setgid with group ownership of NAME @<:@default=no@:>@]),[],[])
 AC_MSG_CHECKING([if using setgid execute bit])
 if test "x$enable_setgid" = "xno" ; then
 GROUPOWNER=
@@ -82,7 +81,7 @@
 
 AC_SUBST(GROUPOWNER)
 
-AC_ARG_ENABLE([scorefile],[AC_HELP_STRING([--enable-scorefile=SCOREFILE], [enable scoreboard with given filename])],[],[])
+AC_ARG_ENABLE([scorefile],[AS_HELP_STRING([--enable-scorefile=SCOREFILE],[enable scoreboard with given filename])],[],[])
 AC_MSG_CHECKING([for scoreboard file])
 if test "x$enable_scorefile" = "xno" ; then
 SCOREFILE=
@@ -103,7 +102,7 @@
 
 AC_SUBST(SCOREFILE)
 
-AC_ARG_ENABLE([logfile],[AC_HELP_STRING([--enable-logfile=LOGFILE], [enable logfile with given filename])],[],[])
+AC_ARG_ENABLE([logfile],[AS_HELP_STRING([--enable-logfile=LOGFILE],[enable logfile with given filename])],[],[])
 AC_MSG_CHECKING([for log file])
 if test "x$enable_logfile" = "xno" ; then
 LOGFILE=
@@ -124,7 +123,7 @@
 
 AC_SUBST(LOGFILE)
 
-AC_ARG_ENABLE([lockfile],[AC_HELP_STRING([--enable-lockfile=LOCKFILE], [enable scoreboard lockfile with given filename])],[],[])
+AC_ARG_ENABLE([lockfile],[AS_HELP_STRING([--enable-lockfile=LOCKFILE],[enable scoreboard lockfile with given filename])],[],[])
 AC_MSG_CHECKING([for scoreboard lockfile file])
 if test "x$enable_lockfile" = "xno" ; then
 LOCKFILE=
@@ -145,7 +144,7 @@
 
 AC_SUBST(LOCKFILE)
 
-AC_ARG_ENABLE([savedir],[AC_HELP_STRING([--enable-savedir=SAVEDIR], [enable systemwide location for saved games])],[],[enable_savedir="no"])
+AC_ARG_ENABLE([savedir],[AS_HELP_STRING([--enable-savedir=SAVEDIR],[enable systemwide location for saved games])],[],[enable_savedir="no"])
 AC_MSG_CHECKING([for save directory])
 if test "x$enable_savedir" = "xno" ; then
 SAVEDIR=
@@ -168,7 +167,7 @@
 
 AC_SUBST(SAVEDIR)
 
-AC_ARG_ENABLE([wizardmode],[AC_HELP_STRING([--enable-wizardmode], [enable availability of wizard mode @<:@default=no@:>@])],[],[])
+AC_ARG_ENABLE([wizardmode],[AS_HELP_STRING([--enable-wizardmode],[enable availability of wizard mode @<:@default=no@:>@])],[],[])
 AC_MSG_CHECKING([if wizard mode is enabled])
 if test "x$enable_wizardmode" = "xno" ; then
 AC_MSG_RESULT([no])
@@ -182,7 +181,7 @@
 AC_MSG_RESULT([yes])
 fi
 
-AC_ARG_ENABLE([allscores],[AC_HELP_STRING([--enable-allscores], [enable scoreboard to show top scores, not just top players @<:@default=yes@:>@])],[],[enable_allscores=yes])
+AC_ARG_ENABLE([allscores],[AS_HELP_STRING([--enable-allscores],[enable scoreboard to show top scores, not just top players @<:@default=yes@:>@])],[],[enable_allscores=yes])
 AC_MSG_CHECKING([if allscores is enabled])
 if test "x$enable_allscores" = "xyes" ; then
 AC_DEFINE([ALLSCORES], [1], [Define if scorefile is top scores, not top players])
@@ -191,7 +190,7 @@
 AC_MSG_RESULT([no])
 fi
 
-AC_ARG_ENABLE([checktime],[AC_HELP_STRING([--enable-checktime], [enable checktime @<:@default=no@:>@])],[],[])
+AC_ARG_ENABLE([checktime],[AS_HELP_STRING([--enable-checktime],[enable checktime @<:@default=no@:>@])],[],[])
 AC_MSG_CHECKING([if checktime is enabled])
 if test "x$enable_checktime" = "xyes" ; then
 AC_DEFINE([CHECKTIME], [1], [Define if checktime feature should be enabled])
@@ -200,7 +199,7 @@
 AC_MSG_RESULT([no])
 fi
 
-AC_ARG_ENABLE([maxload],[AC_HELP_STRING([--enable-maxload], [enable maxload @<:@default=no@:>@])],[],[])
+AC_ARG_ENABLE([maxload],[AS_HELP_STRING([--enable-maxload],[enable maxload @<:@default=no@:>@])],[],[])
 AC_MSG_CHECKING([runtime execution limit (maximum system load average)])
 if test "x$enable_maxload" = "xyes" ; then
 AC_DEFINE([MAXLOAD], [100], [Define if maxload feature should be enabled])
@@ -214,7 +213,7 @@
 AC_MSG_RESULT([$enable_maxload])
 fi
 
-AC_ARG_ENABLE([maxusers],[AC_HELP_STRING([--enable-maxusers], [enable maxuser @<:@default=no@:>@])],[],[])
+AC_ARG_ENABLE([maxusers],[AS_HELP_STRING([--enable-maxusers],[enable maxuser @<:@default=no@:>@])],[],[])
 AC_MSG_CHECKING([runtime execution limit (maximum online system users)])
 if test "x$enable_maxusers" = "xyes" ; then
 AC_DEFINE([MAXUSERS], [100], [Define if maxusers feature should be enabled])
@@ -228,7 +227,7 @@
 AC_MSG_RESULT([$enable_maxusers])
 fi
 
-AC_ARG_ENABLE([numscores],[AC_HELP_STRING([--enable-numscores], [number of scores to store in scoreboard @<:@default=10@:>@])],[],[])
+AC_ARG_ENABLE([numscores],[AS_HELP_STRING([--enable-numscores],[number of scores to store in scoreboard @<:@default=10@:>@])],[],[])
 AC_MSG_CHECKING([what the number of scores to store in scoreboard is])
 if test "x$numscores" = "xyes" ; then
 AC_DEFINE([NUMSCORES], [10], [number of scores to store in scoreboard])
@@ -244,7 +243,7 @@
 AC_MSG_RESULT([$enable_numscores])
 fi
 
-AC_ARG_ENABLE([numname],[AC_HELP_STRING([--enable-numname], [word for number of scores to store in scoreboard @<:@default=Ten@:>@])],[],[])
+AC_ARG_ENABLE([numname],[AS_HELP_STRING([--enable-numname],[word for number of scores to store in scoreboard @<:@default=Ten@:>@])],[],[])
 AC_MSG_CHECKING([word for the number of scores to store in scoreboard is])
 if test "x$enable_numname" = "xyes" ; then
 AC_DEFINE([NUMNAME], ["Ten"], [word for the number of scores to store in scoreboard])
@@ -260,7 +259,7 @@
 AC_MSG_RESULT([$enable_numname])
 fi
 
-AC_ARG_ENABLE([loadav],[AC_HELP_STRING([--enable-loadav=NAMELIST], [use program's load average function (unlikely to work) @<:@default=no@:>@])],[],[])
+AC_ARG_ENABLE([loadav],[AS_HELP_STRING([--enable-loadav=NAMELIST],[use program's load average function (unlikely to work) @<:@default=no@:>@])],[],[])
 AC_MSG_CHECKING([whether to use program's built in load average function])
 if test "x$enable_loadav" = "xyes" ; then
 AC_DEFINE([LOADAV], [], [define if we should use program's load average function instead of system])
@@ -276,7 +275,7 @@
 AC_MSG_RESULT([$enable_loadav])
 fi
 
-AC_ARG_ENABLE([ucount],[AC_HELP_STRING([--enable-ucount=UTMPFILE], [use program's own function to count users (unlikely to work) @<:@default=no@:>@])],[],[])
+AC_ARG_ENABLE([ucount],[AS_HELP_STRING([--enable-ucount=UTMPFILE],[use program's own function to count users (unlikely to work) @<:@default=no@:>@])],[],[])
 AC_MSG_CHECKING([whether to use program's built in user counting function])
 if test "x$enable_ucount" = "xyes" ; then
 AC_DEFINE([UCOUNT], [], [define if we should use program's user counting function instead of system's])