diff rogue5/configure.ac @ 223:0e99eade579c

Generate text documentation from the troff source files. This is done by make, in the 'docs' target, which is now part of the normal build process. Unfortunately, not all the games include troff sources. Getting decent HTML output from groff is still a difficult process which will not be attempted at this time. There are a few bugs in the 'install' and 'uninstall' rules. Not to mention that the documentation is sometimes inaccurate.
author John "Elwin" Edwards
date Sun, 21 Feb 2016 20:47:12 -0500
parents 71cb5b647f2b
children c222f9d56776
line wrap: on
line diff
--- a/rogue5/configure.ac	Fri Feb 12 15:12:37 2016 -0500
+++ b/rogue5/configure.ac	Sun Feb 21 20:47:12 2016 -0500
@@ -5,7 +5,7 @@
 AC_INIT([Rogue],[5.4.5], [yendor@rogueforge.net])
 AC_CONFIG_SRCDIR([armor.c])
 AC_CONFIG_HEADER([config.h])
-AC_CONFIG_FILES([Makefile rogue.6 rogue.cat rogue.doc rogue.html rogue.me])
+AC_CONFIG_FILES([Makefile rogue.6 rogue.me rogue.html])
 
 # Checks for programs.
 AC_PROG_CC
@@ -38,7 +38,6 @@
 AC_CHECK_PROG([GROFF], [groff], [groff],)
 AC_CHECK_PROG([COLCRT], [colcrt], [colcrt],)
 AC_CHECK_PROG([TBL], [tbl], [tbl],)
-AC_CHECK_PROG([SED], [sed], [sed],)
 
 AC_ARG_WITH(program-name, AC_HELP_STRING([--with-program-name=NAME],[alternate executable name]),[progname="$withval" ], [progname="rogue5"] )
 PROGRAM=$progname