diff arogue5/configure.ac @ 122:65f3da34578a

rogue4, arogue5: improve portability. Most changes merely prevent including header files that don't exist. All games now build and run on MinGW, though bugs remain.
author John "Elwin" Edwards
date Wed, 07 May 2014 14:08:38 -0700
parents dfeed24bb616
children 5238b835d661
line wrap: on
line diff
--- a/arogue5/configure.ac	Sat May 03 10:31:30 2014 -0700
+++ b/arogue5/configure.ac	Wed May 07 14:08:38 2014 -0700
@@ -13,7 +13,7 @@
 MP_WITH_CURSES
 # Checks for header files.
 AC_HEADER_STDC
-AC_CHECK_HEADERS([pwd.h errno.h fcntl.h limits.h nlist.h stdlib.h string.h sys/ioctl.h termios.h unistd.h utmp.h term.h ncurses/term.h process.h])
+AC_CHECK_HEADERS([pwd.h errno.h fcntl.h limits.h nlist.h stdlib.h string.h sys/ioctl.h sys/utsname.h termios.h unistd.h utmp.h term.h ncurses/term.h process.h])
 
 # Checks for typedefs, structures, and compiler characteristics.
 AC_TYPE_SIZE_T