diff rogue5/configure.ac @ 221:71cb5b647f2b

Rogue V5: remove troublesome automatic platform detection. configure.ac used AC_CANONICAL_SYSTEM to guess the GNU system description triplets. The target description was substituted into the Makefile and formatted into the filename for the binary distribution tarball. But 'target' is only intended for cross-compilers. 'host_os' might have been a better choice. The tarball filename can still be changed manually, by running make with an argument of 'DESTSYS=systemname'. Cross-compiling may be more difficult now, but I am not certain that it worked properly previously, and due to pending autoconf changes, it was likely to break anyway. The top-level config.guess and config.sub are no longer needed, but they may reappear if better support for cross-compilation is added.
author John "Elwin" Edwards
date Fri, 12 Feb 2016 14:25:47 -0500
parents 3c0abb714974
children 0e99eade579c
line wrap: on
line diff
--- a/rogue5/configure.ac	Fri Jan 22 21:16:54 2016 -0500
+++ b/rogue5/configure.ac	Fri Feb 12 14:25:47 2016 -0500
@@ -6,7 +6,6 @@
 AC_CONFIG_SRCDIR([armor.c])
 AC_CONFIG_HEADER([config.h])
 AC_CONFIG_FILES([Makefile rogue.6 rogue.cat rogue.doc rogue.html rogue.me])
-AC_CANONICAL_SYSTEM([])
 
 # Checks for programs.
 AC_PROG_CC
@@ -276,9 +275,6 @@
 AC_MSG_RESULT([$enable_ucount])
 fi
 
-TARGET=$target
-AC_SUBST(TARGET)
-
 AC_MSG_CHECKING([whether to docdir is defined])
 if test "x$docdir" = "x" ; then
 AC_MSG_RESULT([docdir undefined])