diff rogue4/configure.ac @ 317:aab761616489 default tip

Rearrange some Autoconf files. Autoconf was failing to detect install-sh at the top level and needed some explicit directions. It also wants config.guess and config.sub to be provided too. A few other macros have also been updated.
author John "Elwin" Edwards
date Tue, 05 Sep 2023 20:05:24 -0400
parents 029c1f5c5588
children
line wrap: on
line diff
--- a/rogue4/configure.ac	Sun Oct 31 21:35:53 2021 -0400
+++ b/rogue4/configure.ac	Tue Sep 05 20:05:24 2023 -0400
@@ -6,13 +6,13 @@
 AC_CONFIG_SRCDIR([armor.c])
 AC_CONFIG_HEADERS([config.h])
 AC_CONFIG_FILES([Makefile rogue.6 rogue.me])
+AC_CONFIG_AUX_DIR([../build-aux])
 
 # Checks for programs.
 AC_PROG_CC
 # Checks for libraries.
 MP_WITH_CURSES
 # Checks for header files.
-AC_HEADER_STDC
 AC_CHECK_HEADERS([arpa/inet.h sys/utsname.h pwd.h fcntl.h limits.h nlist.h stdlib.h string.h sys/ioctl.h termios.h unistd.h utmpx.h term.h ncurses/term.h process.h])
 
 # Checks for typedefs, structures, and compiler characteristics.